It is currently Wed Nov 25, 2015 7:26 pm

All times are UTC - 6 hours

Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Weird LED problem
PostPosted: Sun Aug 01, 2010 2:37 am 

Joined: Sun Aug 01, 2010 2:27 am
Posts: 1
I don't know if anyone else has encountered this, but lately the LEDs on my deck have been going out one by one but will sometimes come back very dim or at about half intensity. However once this happens to a key, they never come back to "full life". It's been about two weeks since this occurred and currently there are six keys out and five keys at half intensity. They seem to be randomly distributed and not clustered in one area. Does anyone know what could be happening or how to fix it? Also my power supply is fine and I have tried the keyboard on other computers with the same result.


 Post subject: Re: Weird LED problem
PostPosted: Tue Aug 03, 2010 7:40 am 
Site Admin
User avatar
 WWW  Profile

Joined: Tue Aug 09, 2005 1:48 pm
Posts: 463
Location: Kenosha, WI
It is hard to determine what the cause may be without inspecting the individual board...for returns for repair see this page:

Deck Guy Adam - The best backlit keyboards on Earth - Parent company of Deck, leaders in custom industrial keyboards


Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 6 hours

Who is online

Users browsing this forum: Google [Bot] and 4 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group  
Design By Poker Bandits