It is currently Thu Oct 23, 2014 2:17 am

All times are UTC - 6 hours





Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: Dead deck... Problem fixed, thanks admin.
PostPosted: Mon Apr 06, 2009 4:01 pm 
Offline
 Profile

Joined: Fri Mar 27, 2009 12:54 pm
Posts: 11
I just received my new deck legend today. I bought it from performance-pcs.com so I could only get the standard version instead of mac. I thought I could simply plug and play, that my mac would recognize it, but no such luck so far. Does anybody have any suggestions, I'd hate to have to return or exchange a keyboard I've been looking forward to using so much.

Edit: ok I just plugged this thing into my old windows pc and it's not working there either. It seems to be completely dead. No lights, no anything.


Last edited by shortround on Wed Apr 08, 2009 10:14 pm, edited 1 time in total.

Top
 

 Post subject: Re: Dead deck.
PostPosted: Tue Apr 07, 2009 5:35 am 
Offline
Site Admin
User avatar
 WWW  Profile

Joined: Tue Aug 09, 2005 1:48 pm
Posts: 463
Location: Kenosha, WI
One thing to check is the cable, once in a blue moon they get disconnected inside the housing. To do this, remove the 11 phillips head screws from the bottom of the housing, remove the top housing half, and then check the cable connection. Usually this is the culprit when it is completely dead without even lighting up.

If that doesn't fix it, email me at technicalsupport@deckkeyboards.com and I will work with you to make it right.

_________________
Deck Guy Adam
http://www.deckkeyboards.com - The best backlit keyboards on Earth
http://www.tg3electronics.com - Parent company of Deck, leaders in custom industrial keyboards


Top
 

 Post subject: Re: Dead deck.
PostPosted: Wed Apr 08, 2009 9:21 pm 
Offline
 Profile

Joined: Fri Mar 27, 2009 12:54 pm
Posts: 11
Alright!! Now we're cooking. It was the cable connection inside. I'm so glad I checked the forum, thanks Adam. Simple problem and simple fix. This thing is lit up like a christmas tree now. You saved me an exchange.


Top
 

 Post subject: Re: Dead deck... Problem fixed, thanks admin.
PostPosted: Thu Apr 09, 2009 11:15 am 
Offline
 Profile

Joined: Tue Dec 16, 2008 11:12 am
Posts: 11
I also bought it from Performance-PCs.com and have the same problem. They should really uhh... make sure it works before they send it? Anyways, I'll try checking what the dude up there suggested

_________________
Image


Top
 

 Post subject: Re: Dead deck... Problem fixed, thanks admin.
PostPosted: Thu Apr 09, 2009 11:17 am 
Offline
Site Admin
User avatar
 WWW  Profile

Joined: Tue Aug 09, 2005 1:48 pm
Posts: 463
Location: Kenosha, WI
We always test them before shipping from our factory so I am concerned as to how this would happen. It's pretty rare that 2 people who purchased from Performance-PCs would have the same problem...will look into this.

_________________
Deck Guy Adam
http://www.deckkeyboards.com - The best backlit keyboards on Earth
http://www.tg3electronics.com - Parent company of Deck, leaders in custom industrial keyboards


Top
 

 Post subject: Re: Dead deck... Problem fixed, thanks admin.
PostPosted: Thu Apr 09, 2009 12:08 pm 
Offline
 Profile

Joined: Tue Dec 16, 2008 11:12 am
Posts: 11
Alright thanks a lot, it was the loose connection. It happened again after I screwed it back together the first time, so the second time I decided to plug it in and keep it plugged in while I screwed it back together to make sure that it stayed in. Thanks for the help!

_________________
Image


Top
 

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC - 6 hours



Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group  
Design By Poker Bandits